Quantcast

warning from autoconf

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

warning from autoconf

Kemin Zhou

autoscan Unescaped left brace in regex is deprecated, passed through in regex; marked by <— HERE in m/\${ <— HERE [^\}]*}/

when running autoscan 2.69 (2012 release) I got this error message. It is a simple error in the perl code. autoscan is part of autoconf.

Problem at autoscan line 361.It is just a perl warning. Kemin Zhou 858 771-3269
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: warning from autoconf

Eric Blake-3
On 12/20/2016 10:44 PM, Kemin Zhou wrote:
>
> autoscan Unescaped left brace in regex is deprecated, passed through in regex; marked by <— HERE in m/\${ <— HERE [^\}]*}/

Thanks; you're the second person to report this in a month, so I'll get
it fixed soon.

--
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org


signature.asc (617 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: warning from autoconf

Eric Blake-3
On 12/21/2016 08:37 AM, Eric Blake wrote:
> On 12/20/2016 10:44 PM, Kemin Zhou wrote:
>>
>> autoscan Unescaped left brace in regex is deprecated, passed through in regex; marked by <— HERE in m/\${ <— HERE [^\}]*}/
>
> Thanks; you're the second person to report this in a month, so I'll get
> it fixed soon.

In fact, the patch is already applied, and we are just waiting on the
release:

http://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=e5654

--
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org


signature.asc (617 bytes) Download Attachment
Loading...