Quantcast

[PATCH] autoreconf: Support AM_GNU_GETTEXT_REQUIRE_VERSION

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[PATCH] autoreconf: Support AM_GNU_GETTEXT_REQUIRE_VERSION

Michał Górny
As reported in https://github.com/gentoo/gentoo/pull/163, gettext 0.19.6
supports using AM_GNU_GETTEXT_REQUIRE_VERSION instead of
AM_GNU_GETTEXT_VERSION. Update autoreconf to support both.

Signed-off-by: Michał Górny <[hidden email]>
---
 bin/autoreconf.in | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/bin/autoreconf.in b/bin/autoreconf.in
index 9f353b0..db408f7 100644
--- a/bin/autoreconf.in
+++ b/bin/autoreconf.in
@@ -264,7 +264,7 @@ sub autoreconf_current_directory ()
   s/dnl.*//;
   $uses_autoconf = 1 if /AC_INIT/;
   # See below for why we look for gettext here.
-  $uses_gettext = 1  if /^AM_GNU_GETTEXT_VERSION/;
+  $uses_gettext = 1  if /^AM_GNU_GETTEXT_(REQUIRE_)?VERSION/;
  }
     }
   if (!$uses_autoconf)
@@ -435,9 +435,9 @@ sub autoreconf_current_directory ()
     }
 
   # Gettext consistency checks...
-  error "$configure_ac: AM_GNU_GETTEXT is used, but not AM_GNU_GETTEXT_VERSION"
+  error "$configure_ac: AM_GNU_GETTEXT is used, but not AM_GNU_GETTEXT_VERSION or AM_GNU_GETTEXT_REQUIRE_VERSION"
     if $uses_gettext_via_traces && ! $uses_gettext;
-  error "$configure_ac: AM_GNU_GETTEXT_VERSION is used, but not AM_GNU_GETTEXT"
+  error "$configure_ac: AM_GNU_GETTEXT_VERSION or AM_GNU_GETTEXT_REQUIRE_VERSION is used, but not AM_GNU_GETTEXT"
     if $uses_gettext && ! $uses_gettext_via_traces;
 
 
--
2.6.1


Loading...