Fwd: installation of automake, autoconf, m4 error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Fwd: installation of automake, autoconf, m4 error

Krishnan Rajiyah
---------- Forwarded message ---------
From: Krishnan Rajiyah <[hidden email]>
Date: Mon, Jun 29, 2015 at 10:40 AM
Subject: installation of automake, autoconf, m4 error
To: <[hidden email]>, <[hidden email]>


Hello GNU,

I have been trying to install automake, autoconf, and m4 on my
NetBSD-4.0.1-x68k system. As I understand from your website, automake
requires autoconf which requires m4 which requires perl. I havent installed
perl yet, because I am getting errors saying that it cant make built-in
(still trying to find a way around this).

However, the problem I had with m4 make was not with perl, it said that
automake-1.14 was missing from the system. This does not make sense since
that would mean that there would be a cycle in the dependency tree.

I am trying to install the latest version of autoconf (2012 release), the
latest version of m4 (2013 release), and the second latest verison of
automake (2013 release).

Can you please tell me what I am doing wrong? Is your software even
compatible with a NetBSD-4.0.1-x68k system?

Thanks,
Krishnan Rajiyah
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: bug#20941: Fwd: installation of automake, autoconf, m4 error

Mathieu Lirzin
Hello,

Krishnan Rajiyah <[hidden email]> writes:

> ---------- Forwarded message ---------
> From: Krishnan Rajiyah <[hidden email]>
> Date: Mon, Jun 29, 2015 at 10:40 AM
> Subject: installation of automake, autoconf, m4 error
> To: <[hidden email]>, <[hidden email]>
>
> Hello GNU,
>
> I have been trying to install automake, autoconf, and m4 on my NetBSD-4.0.1-x68k system. As I understand from your website, automake requires autoconf which requires m4 which requires perl. I havent
> installed perl yet, because I am getting errors saying that it cant make built-in (still trying to find a way around this).
>
> However, the problem I had with m4 make was not with perl, it said that automake-1.14 was missing from the system. This does not make sense since that would mean that there would be a cycle in the
> dependency tree.
>
> I am trying to install the latest version of autoconf (2012 release), the latest version of m4 (2013 release), and the second latest verison of automake (2013 release).
>
> Can you please tell me what I am doing wrong? Is your software even compatible with a NetBSD-4.0.1-x68k system?

When building a package from a tarball, Unless something fishy happened
in the distribution process, Automake should not be required.  Maybe you
were trying to build m4 from the git repository?  I have successfully
built m4-1.4.18 tarball on my system without requiring Automake.

Thanks for the bug report.

--
Mathieu Lirzin
GPG: F2A3 8D7E EB2B 6640 5761  070D 0ADE E100 9460 4D37

Loading...